Краткое описание приложения

Компонента дополняет функционал мобильной платформы 1С возможностями, которые на данный момент не доступны. Компонента интегрируется в макет конфигурации на 1С. При подключении данной компоненты становятся доступны дополнительные возможности.
Функциональные возможности
Получения внешних событий при получения данных со встроенного NFC считывателя
Для чтения данных с NFC метки просто подключите драйвер и обработчик оповещения в модуле формы

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
            
    Если Источник = "ПодключаемоеОборудование"
        И ИмяСобытия = "RFID"
        И ВводДоступен() Тогда
        
        NFCданные = Параметр;
        
    КонецЕсли;
КонецПроцедуры
Возможность генерации штрих-кодов
Если нужно на экране мобильного устройства сформировать и вывести штрих-код или QR-код, нет не чего проще просто выполняете вот такую процедуру:

&НаКлиенте
Процедура СформироватьИзображениеШК()    
    ЭтаФорма.КартинкаШтрихкода = "";    
    #Если МобильноеПриложениеКлиент Тогда

        Если ЗначениеЗаполнено(Штрихкод) Тогда
            ЗначениеBase64 = глВКRSDriver.ВызовЯдра("BarCreator:createBarcode", Штрихкод,ТипШтрихкода, ШиринаШтрихкода, ВысотаШтрихкода);
            ЭтаФорма.КартинкаШтрихкода = ПоместитьВоВременноеХранилище( Base64Значение(ЗначениеBase64), ЭтаФорма.УникальныйИдентификатор) ;
        КонецЕсли;
    
    #КонецЕсли    
КонецПроцедуры
Получения внешних событий при нажатии на физических кнопок на устройстве
Мы получаем scancode клавиши которая была нажата на МУ и можем заложить определенную обработку под это нажатие или использовать как ввод данных с физических клавиш.
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    
    Если Источник = "ПодключаемоеОборудование"
        И ИмяСобытия = "KeyPress"
        И ВводДоступен() Тогда
        
        Сканкод = Параметр;
        
    КонецЕсли;
КонецПроцедуры
Получения внешних событий при получения данных со встроенного в ТСД сканера штрих кодов
Вот таким образом можно получать данные от сканера ШК. Простой обработкой оповещения, без активного окна. данные получаются без задержек.

&НаКлиенте
Процедура ОбработкаОповещения (ИмяСобытия, Параметр, Источник)
    Если Источник = "ПодключаемоеОборудование"
        И ИмяСобытия = "Barcode" И ВводДоступен() Тогда
        
        Штрихкод = Параметр;
        
    КонецЕсли;
КонецПроцедуры
Возможность записи данных на NFC
Все тоже проще не куда...
Для записи данных на NFC создаем XML структуру такого типа:
<?xml version="1.0"?>
<tag id="4EF345F6">
    <sector id="1">
        <block id="1">0x10,0x22,0x22,0x22
    </sector>
</tag>

и записываем ее на карту

#Если МобильноеПриложениеКлиент Тогда
    Попытка
        глВКRSDriver.ВызовЯдра("IO:writeNfc",XMLСтрока);    
    Исключение
    КонецПопытки;
#КонецЕсли
Монитор файлов
Если нужно узнать о появление файла на мобильном устройстве и к примеру сразу его обработать или выполнить еще какие-то действия.

ИмяКаталога = "/sdcard/DCIM/";
глВКRSDriver.ВызовЯдра("IO:addListener",ИмяКаталога);

и далее просто получаем уведомление в случае появлении новых файлов по этому адресу

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = ":IO.FileListener" Тогда
        ИмяФайла = Параметр;
    КонецЕсли;
КонецПроцедуры
Проигрывание звуковых файлов
Проигрывание звуковых оповещений для подсказки действия пользователю

&НаКлиенте
Процедура rsBEEP(Команда)     
    #Если МобильноеПриложениеКлиент Тогда
        Попытка
            глВКRSDriver.ВызовЯдра("1C.8.3.9:beep");
        Исключение
            Сообщить(ОписаниеОшибки());
        КонецПопытки;     
    #КонецЕсли     
КонецПроцедуры
Воспроизводить голосом текст
Если необходимо пользователю не только оповестить сигналом но и сказать что-то. можно использовать данный код и пользователь услышит машинный голос Google

&НаКлиенте
Процедура СинтезаторРечи(Команда)
    #Если МобильноеПриложениеКлиент Тогда
        ВведенныйТекст = "Тест пользователю";
        Попытка
            глВКRSDriver.ВызовЯдра("IO:say", ВведенныйТекст);
        Исключение
            Сообщить(ОписаниеОшибки());
        КонецПопытки;        
    #КонецЕсли    
КонецПроцедуры

Часто задаваемые вопросы

  • Можно ли использовать приложение RS:DRIVER с другими терминалами сбора данных (не только с UROVO)?

  • Если терминалы сбора данных UROVO были куплены не у официальных дистребьютеров, то будет ли поддерживаться RS:DRIVER?

  • Сможет ли программист компании, купившей терминал сбора данных самостоятельно разработать конфигурацию на 1С для ТСД